Bookmarking - Preview is not displaying

We are often asked why nothing displays in the preview pane when bookmarking.

There are two reasons for this:

1 - In a lot of cases it will be because you are running reading list on https so you url is now https://<tenancyshortcode>.rl.talis.com and websites you are bookmarking from are http.

This means the iframe cannot display insecure content on a secure page

If you access your library catalogue as https and bookmark you will most likely see a preview, for instance:

https://broadminstercatalogue/record=b2714904

Bookmarking from an http website means you will not see a preview, for example: http://<broadminstercatalogue/record=b2714904

This is not something we can change as the browser itself has this control, and in the inspector/console, accessed usually by a right click on the page and displays page loading errors or warnings will have a warnig similar to this

Mixed Content: The page at 'https://demo.rl.talis.com/ui/forms/bookmarklet.html?fast=true&targetTitl…' was loaded over HTTPS, but requested an insecure resource 'http://broadminstercatalogue/record=b2714904'. This request has been blocked; the content must be served over HTTPS.

2 - The website you are bookmarking from cannot be loaded in an iframe, and the preview pane on the right hand side of the bookmarking screen is an iframe.

This can happen regardless of https and http, and is controlled by the webpage. The symptoms of this is the bookmarking screen not completing the bookmarking process and instead jumping back to the page you wish to bookmark. What we are able to do is to add this web address to a watchlist so that we don't attempt to load it in an iframe but instead display a link to the original page you are bookmarking from. 

 

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk